Oficina/Inkscape

De PoliGNU Wiki
Ir para: navegação, pesquisa

Recursos Básicos

Página

  • Como configurar a página a ser trabalhada?
    • Arquivo > Propriedades do Desenho

Oficina Inkscape Config Pagina.png

  • É possível configurar a página para se adequar a uma determinada seleção de objetos neste mesmo menu.

Camadas

Este é o símbolo que ativa a barra de ferramentas de camadas: Simbolo barra camadas.png

Esta é a imagem padrão da barra de ferramentas de camadas. Nela temos alguns recursos:

  • Lista de todas as camadas e subcamadas aninhadas.
  • Ao lado esquerdo de cada camada temos dois ícones, um "olho" e um "cadeado".
O "olho" habilita ou desabilita a visualização da camada (e todas as subcamadas!).
O "cadeado" trava ou destrava edições naquela camada (e todas as subcamadas da mesma). Caso uma camada esteja "travada" ela sequer poderá ser selecionada.
  • As camadas mais "acima" na lista ficam "acima" também na imagem final, elas sobrepõem o conteúdo das camadas "inferiores".
  • Abaixo da lista de camadas temos alguns botões:
  • Adicionar nova camada
  • Move a camada selecionada para acima de todas as outras.
  • Move a camada selecionada uma posição acima.
  • Move a camada selecionada para baixo de todas as outras.
  • Move a camada selecionada uma posição abaixo.
  • Remover Camada.
  • Por fim destaca-se também a possibilidade de calibrar a opacidade da respectiva camada (e suas subcamadas).
  • Observação: Para aplicar qualquer um dos recursos numa camada ela precisa estar selecionada.

Lista camadas.png

Por fim, temos a janela de adicionar uma nova camada. Nesta janela escolhe-se o nome da camada e a Disposição da mesma.

A disposição é sempre relativa à camada selecionada no momento em que se deseja adicionar a nova camada. Adicionar camadas.png

Agrupamento

Agrupar objetos é algo sempre útil, principalmente quando se deseja movimentar o conjunto sem interferir no alinhamento entre os itens desse conjunto.

O comando de teclado para agrupar objetos é o CTRL+G. Todos os objetos selecionados serão agrupados.

Para desagrupar objetos basta utilizar-se do atalho CTRL+SHIFT+G.

A um grupo de objetos é possível alterar propriedades de cor, opacidade/transparência, movimentar o agrupamento, etc.

Destaca-se o fato de que ao se agrupar objetos de diferentes camadas estes objetos serão movidos para uma única camada. Deve-se tomar cuidado com o agrupamento quando se trabalha com diversas camadas.

Alinhamento e Distribuição de objetos

Ao diagramar materiais por vezes desejamos alinhar objetos entre si, ou com relação à página.

Para isso, no inkscape temos a barra de ferramentas de "Alinhamento e Distribuição de Objetos", cujo ícone para habilitar a barra é: Alinhar simbolo.png

A visão geral da barra de ferramentas "Alinhamento e Distribuição" é esta: Alinhar barra completa.png

Nela podemos observar que a primeira coisa a ser feita é definir com relação a quem será feito o alinhamento. As opções de referência de alinhamento são as seguintes:
Alinhar relativo a.png
  • Alinhamento Relativo a:
Último Selecionado: Os objetos selecionados serão alinhados com relação ao último que foi selecionado. Neste caso o último selecionado não é movimentado.
Primeiro Selecionado: Os objetos selecionados serão alinhados com relação ao primeiro que foi selecionado. Neste caso o primeiro selecionado não é movimentado.
Maior objeto: Os objetos selecionados serão alinhados com relação ao maior dos objetos selecionados. Neste caso, este (maior) não é movimentado.
Menor objeto: Os objetos selecionados serão alinhados com relação ao menor dos objetos selecionados. Neste caso, este (menor) não é movimentado.
Página: Todos os objetos selecionados são alinhados com relação à página.
Desenho: Todos os objetos selecionados são alinhados com relação ao desenho. No âmbito do Inkscape considera-se Desenho a área total ocupada por todos os objetos existentes no arquivo SVG aberto. O Desenho independe completamente da página.
Seleção: Todos os objetos selecionados são alinhados com relação à área de seleção definida naquele instante.

A seguir encontramos um checkbox "Tratar seleção como agrupamento:". Caso este checkbox esteja marcado todos os objetos selecionados serão considerados como um "objeto único" e este "objeto único" é que será alinhado.

Após encontramos as opções de alinhamento.

Preenchimento e Contorno

Para habilitar o painel de Preenchimento e Contorno o ícone na barra de ferramentas é: Preenchimento icone.png

No painel podemos observar 3 abas:

  • Preenchimento
  • Cor do Contorno
  • Contorno

Preenchimento

A aba preenchimento é a responsável pelas cores internas do objeto.

Preenchimento barra completa.png

Os primeiros elementos que encontramos são relativos à forma de preenchimento, contendo as seguintes opções:

  • Sem Cor
  • Cor Uniforme
  • Gradiente Linear: Após definir o gradiente a ser usado no objeto define-se a direção e a intensidade de variação das cores.
  • Gradiente Radial: Após definir o gradiente a ser usado no objeto define-se a intensidade de variação das cores.
  • Padrão: Preenche conforme o padrão selecionado
  • Amostra
  • Indefinido: Permite herdar as configurações de cor

A seguir encontramos as opções de preenchimento, que variam para cada um dos tipos de preenchimento existentes.

Por fim temos as opções de desfoque e opacidade.

Cor do Contorno

Em Cor do Contorno é que definiremos as cores dos contornos (bordas) de nossos elementos.

Cor contorno barra completa.png

Suas opções são idênticas à do Preenchimento.

Contorno

Na Aba de Contorno encontramos descrições e opções para configurar como será o contorno do objeto selecionado.

Contorno barra completa.png

Contamos com as seguintes opções:

  • Espessura: define a espessura do contorno
  • Cantos: Define a forma dos cantos do contorno
  • Limite do aguçamento: Aguçamento dos cantos
  • Extremidades: Define a forma das extremidades dos contornos
  • Estilos: Define o estilo do contorno
  • Marcadores Iniciais: Define marcadores iniciais ao contorno
  • Marcadores Centrais: Define marcadores centrais ao contorno
  • Marcadores Finais: Define marcadores finais ao contorno

Além disso existem ainda as opções Desfoque e Opacidade.

Auto-Alinhamento

Snap barra completa.png

Auto-alinhamento é o recurso que faz com que o objeto, ao ser arrastado com o mouse, se alinhe ao chegar a uma determinada distância de um objeto, seguindo algumas regras.

Em outros programas em inglês este recurso é chamado de snap.

Em geral é a barra que fica à direita da tela, e seu ícone principal de ativação é Snap ico.png.

Outra forma de ativar este painel é indo ao menu Exibir > Auto-alinhamento.

Além disso, esse alinhamento pode ocorrer com relação a diversos pontos de referência como:

  • Alinhar cantos de caixas delimitadoras: Este item ativa as opções de snapcom relação às bordas de caixas delimitadoras.
    • Alinhar às bordas de caixas delimitadoras
    • Alinhar aos cantos de caixas delimitadoras
    • Alinhar de, e à pontos centrais de bordas de caixas delimitadoras
    • Alinhar de, e aos centros de caixas delimitadoras
  • Alinhar nós ou alças: Habilita o "snap" referentes a nós de elementos, não mais apenas às bordas.
    • Alinhar a caminhos
    • Alinhar a intersecções de caminhos
    • Alinhar aos nós cúspides
    • Alinhar aos nós suaves
  • Alinhar de, e aos pontos centrais de segmentos de linhas
  • Alinhar de, e aos pontos centros dos objetos
  • Alinhar de, e aos centros de rotação de um objeto
  • Alinhar às bordas das págnas
  • Alinhar às grades
  • Alinhar às guias

Exportando

Uma parte não menos importante que fazer um bom material gráfico é exportá-lo corretamente para ser utilizado nos mais diversos meios.

Além do formato nativo do Inkscape, que é o svg - um padrão aberto e internacional para desenhos vetoriais suportado pelos browsers mais modernos; outras formas de trocar os materiais são arquivos de imagem não vetorial (pixelizada) como o PNG e o formato PDF (este muito útil para dialogar com gráficas que não conhecem e/ou trabalham com SVG).

Formato não vetorial (PNG)

Para exportar como imagem não vetorial ('bitmap') o padrão que utilizamos é o PNG. O botão da barra de ferramentas para exportar é este: Arquivo:Export png ico.png

Outra forma de chamar a janela de exportação para bitmap é no menu Arquivo > Exportar para Bitmap.

Na tela de exportação encontramos algumas opções:

  • Exportar Área: Primeiramente o que queremos exportar, sendo que geralmente utilizamos "Página" ou "Seleção":
    • Página
    • Desenho
    • Seleção
    • Personalizado
  • Dimensões do Bitmap: Aqui definiremos as dimensões finais do arquivo exportado, sendo elas em pixels ou em DPI (dots per inch ou pontos por polegada)
  • Nome do arquivo: por fim, ao clicar em Navegar, abre-se uma janela perguntando aonde se deseja salvar o arquivo. Não se esqueça de, nesta janela que se abre, colocar o nome do arquivo e colocar a extensão .png antes de clicar "ok".

Uma dica interessante para divulgações online (email) de materiais digitais é que o arquivo final não tenha muito mais que 150kb. Este é um valor que, quando ultrapassado, é barrado em vários filtros de email, indo parar na caixa de SPAM.

Formato Vetorial de 'Intercâmbio' (PDF)

Para impressões e plotagens, um bom formato de troca é o PDF. Ele mantém as características vetoriais e geralmente pode ser aberto em qualquer computador (apesar de não poder ser editado).

Para exportar no formato PDF vá em Arquivo > Salvar Como.

Em seguida, no canto inferior direito da janela selecione o formato em que deseja salvar (normalmente estará em "Inkscape SVG(*.svg)"). Neste caso optaremos por "Portable Document Format(*.pdf)".

Selecione aonde você deseja salvar o arquivo e com qual nome e em seguida clique em "Salvar". Neste instante será aberta a tela de exportação para PDF.

Nesta tela podemos selecionar a versão que queremos usar do padrão PDF (normalmente não alteramos isso).

Além disso, temos as outras seguintes opções:

  • Converter textos em caminhos: Caso você tenha utilizado alguma fonte que não tenha no computador em que o PDF será aberto, provavelmente o PDF será aberto com uma fonte "padrão", desconfigurando assim o que você havia previsto. Para evitar isso exportam-se os textos como curvas, garantindo a correta formatação de todos os textos em qualquer computador.
  • PDF+LaTeX: Omite texto em PDF, e cria um arquivo LaTeX: Esta opção exporta o PDF e também um arquivo LaTeX, permitindo que o texto fique independente do PDF -> pouco comum de se utilizar.
  • Rasterizar efeitos de filtros: transforma as imagens vetoriais em imagens "raster" (pixelizada).
  • Resolução para rasterização (dpi): Qualidade com a qual se deseja rasterizar o documento.
  • Exportar desenho: Exporta todo o desenho do arquivo SVG aberto, mesmo o que está "fora da página".
  • Exportar página: Exporta apenas o que está dentro da área da página definida.

Vetorizando imagens

Textos

Texto para caminho

Texto em molde

Referências